
Step 1 

Open Maya and set the proper project folder for your project. Go to File>Project>New and 
write down the name of the project and location, then click on “Use Default”. 

 

 



Step 2 

Now let’s bring the reference image into the viewport. Go to View>Image Plane>Import 
Image and open the image in the Front view. 

 

 

 



Step 3 

Now let's start modeling. As you can see the whole gun has a flat surface. So we will start 
with the easiest and lowest poly part of the gun. The red arrow denotes the part. 

 

Step 4 

Go to Mesh>Create Polygon Tool and create the necessary shape according to the part. 

 



Step 5 

Now go to Edit Mesh>Split Polygon Tool and with the help of the Split Polygon Tool, draw 
depth edges for the screws as shown. 

 

Step 6 

Now go to the Perspective view and extrude the border edges to create depth. To extrude 
go to Edit Mesh>Extrude. 

 



Step 7 

One more thing I would like to tell you is to turn on the "wire-frame on shaded" option for 
the best visibility of the geometry. For this, go to Shading>Wireframe on Shaded. Now 
create a Cylinder to form a screw. Modify it, delete the center face of the cylinder and 
extrude it from the center border edges. 

 

Step 8 

Now put the screw in it's place, and go to Edit>Duplicate Special to create the other 
screws as well. 

 



Step 9 

Now we will create the next part of the gun. Again go to Mesh>Create Polygon Tool, and 
create the shape using proper loops of edges as shown in the image below. 

 

Step 10 

As you can see here, there is a depth line on the gun. We make this with the help of the 
Split Polygon Tool. So go to Edit Mesh>Split Polygon Tool and on the curves of the lines 
we will make proper loops. 

 



Step 11 

Once it is done, we will combine both the meshes together. So go to Mesh>Combine and 
then extrude from the front, also extrude the line faces a negative amount. Look at the far 
end of the extruded line that the arrow is showing, this line will not go forward from here. 
And then place the screws here too which were created in the previous steps. 

 

Step 12 

Now let’s create the metal design with the help of the Create Polygon Tool. First create 
the back plane of the metal design and then add three cylinders there. Take a copy of a 
screw (scale it if needed) and fill the center hole. For that, double click on the Centrex 
border edges, go to Mesh>Fill Hole and then extrude it outward. 

 



Step 13 

Now we will create the bullet refill. The create polygon tool is an amazing tool if you know 
how to use it according to your model. In the front viewport, create a polygon for the bullet 
refill with the help of create polygon tool. 

 

Step 14 

Now complete the loops and extrude the border edges and some faces as shown in the 
figure below. 

 



Step 15 

Now create a box to make the bullets. Insert edge loops, one in the center from the top 
and front of the box, and two edge loops on both sides of the box as you can see in the 
image. To insert edge loops, go to Edit>Insert Edge Loop Tool and drag the pointer on 
edge. 

 

Step 16 

Now go to vertex mode and transform the box as shown in the figure below. 

 



Step 17 

Now move the bullet inside the bullet refill and go to Edit>Duplicate Special (click on the 
box). Select the Instance option and write the desired number of bullets in the copy box. 

 

Step 18 

Now let’s make a small embossed design. Go to Mesh>Create Polygon Tool and create a 
polygon as you can see in the figure below, and draw an edge on it using the Split 
Polygon Tool. 

 



Step 19 

First select the edge loop1 and move it outside as shown in the figure below. I have 
mentioned the name in the figure so you can easily understand. Then select the last edge 
and extrude it behind. 

 

Step 20 

Again using the create polygon tool, create a polygon as you can see in image shown 
below. Go to Mesh>Create Polygon Tool to select the tool. 

 



Step 21 

With the help of the Split Polygon Tool, complete the loops where you can see vertices. 
For the Split Polygon Tool, go to Edit Mesh>Split Polygon Tool. 

 

Step 22 

Now create and adjust the mesh according to the reference image or model as you can 
see in the figure. 

 



Step 23 

Now this is the time to do some detailing. Go to the Perspective view, select some faces 
and extrude them backward. For extrude go to Edit Mesh>Extrude. 

 

Step 24 

Again extrude the last faces outward. 

 



Step 25 

Select the faces below and move them backward. 

 

Step 26 

Select some of the border edges and extrude them back as you can see in the figure. I'm 
showing you from behind just so you understand how many edges we need to select. 

 



Step 27 

Scale the faces from center as you can see in the figure, and also extrude the faces where 
we have to put screws. The arrows are showing the faces. 

 

Step 28 

And give it a narrow shape where the arrows are showing. 

 



Step 29 

Now before we go ahead, we will do an essential task. Duplicate what we have made so 
far to the other side. By doing this we will be able to understand the proportions of the 
model. First of all select the whole gun and press Ctrl+G to create a group. Go 
to Edit>Duplicate Special (click on the option box) and set the scaling value of the Z Axis 
to -1.000 and do not click on instance. We set the value of the Z Axis to -1.000 because 
when we copy the model to the other side it will automatically be set opposite to the Z-
Axis. 

 
  



Step 30 

Move the other duplicated side opposite to the Z-Axis. 

 

Step 31 

In the Front view, take the “Create Polygon Tool” and create a polygon according to the 
reference. 

 



Step 32 

Connect vertex to vertex and complete the loops. 

 

Step 33 

Go to the Perspective View and give it the required shape by moving the vertices. 

 



Step 34 

Select the bottom edges and extrude them backwards. For extrude go to Edit 
Mesh>Extrude. 

 

Step 35 

Put it in it's right place. Remember it is a separate mesh, we do not combine it with any 
other part. Go to Edit Mesh>Insert Edge Loop Tool or Split Polygon Tool and insert edge 
loops on left side and then select the faces in the loops and extrude Them backward. 

 



Step 36 

Select the left side border edges and extrude them outward. Similarly select the right side 
border edges and extrude them inward. See the image. 

 
  



Step 37 

Now go to Edit>Duplicate Special and copy the half mesh to the other side. Remember, 
just keep copying and don't combine both sides. We will do that later and I will show you 
how to do it. 

 
  



Step 38 

Let’s move to the next part. While in the front view, go to Mesh>Create Polygon Tool, 
select Create Polygon Tool and create a polygon as I'm showing you in the figure below. 

 

Step 39 

Connect vertex to vertex and create the loops. 

 



Step 40 

Select the border edges and extrude them as you can see in the figure. 

 

Step 41 

Now go to Edit Mesh>Split Polygon Tool and create a line according to our reference. 

 



Step 42 

Select the faces along the line and extrude them. 

 

Step 43 

For smoothness, let’s add some edges and spread them out from the center (The red 
arrow is pointing to them). You can check it by pressing the 3 key for smoothness mode, 
and press the 1 key to go back into hard mode. 

 



Step 44 

Now we have to make some room for the trigger. Go to Edit Mesh>Insert Edge Loop 
Tool and insert an edge loop. Select some faces (as you can see in the figure) and delete 
them. 

 

Step 45 

In the Perspective View, select some edges and extrude them to the left side. 

 



Step 46 

You will have to change its shape slightly from top view. 

 

Step 47 

Use “Duplicate Special” and copy it to the opposite side. 

 



Step 48 

Select the border edges and extrude them inside. 

 

Step 49 

Now we can make the trigger. Create a Box in the Front view. 

 



Step 50 

Go to Edit Mesh>Insert Edge Loop Tool and add some edges and then modify it as I did. 
Delete the back faces. 

 

Step 51 

Go to Mesh>Create Polygon Tool and create the shape according to the figure below. 

 



Step 52 

Make edge loops on the polygon and then select border (except the top edge) and extrude 
it a little bit backward. Then again extrude from all sides, except the top edge. 

 
  



Step 53 

Then insert an edge loop where the arrow is pointing in the image below. Select the 
border (except the top edge) and extrude it backward. Again extrude one more time, but 
this time deselect the edges below the edge loop where the arrow is pointing. 

 

Step 54 

Select the front side faces and extrude and scale inward, then again extrude outward. 
Delete the top face. 

 



Step 55 

Insert two more edges to make two stripes. Select the faces of the stripes and extrude 
them inward from all sides. 

 

Step 56 

Put it in its right place and modify as needed. 

 



Step 57 

With the help of duplicate special make a copy on other side. 

 

Step 58 

In the Front view, create a Box and give it the shape according to the reference object. 

 



Step 59 

Go to Edit Mesh>Insert Edge Loop Tool, insert three edge loops and one from the top. 

 
  



Step 60 

Insert edge loops from the front view and delete the back, left & right side faces. Give it a 
narrow shape from right side, and just move three vertices as I have shown by the arrows. 

 

Step 61 

Extrude it from the left side according to our model and as you can see in the figure below. 

 



Step 62 

Now we'll make the blocks that remain on it. With the help of the Split Polygon Tool, create 
a block shape on the mesh and modify it slightly. 

 

Step 63 

Select the faces of the blocks that we just created and extrude them backward. Because 
the upper part of the mesh will not show up, therefore you give it any shape as you want. 

 



Step 64 

Now, by using the Duplicate Special option, copy it to the opposite side. 

 
  



Step 65 

Now we will make the largest part of the gun. There are other ways too to model this gun, 
it is not necessary that you only use the Create Polygon Tool. You can also use a box to 
model this part. So create a Box in the Front view as our reference. One more thing that I 
want to tell you is if you have any problem with other parts, like heaviness in the view port 
of the perspective view, you can go to Show>Isolate Select>View Selected and only select 
the object that you want to keep visible. Also select the image plane otherwise it will 
disappear too. But If your viewport is not heavy then you don't need to do it. 

 
  



Step 66 

Go to Edit Mesh>Insert Edge Loop Tool and insert three edge loops vertically as you can 
see in the figure below. 

 

Step 67 

Select the bottom and back faces and delete them. 

 



Step 68 

Select three edges and extrude them down. And adjust them a little bit. 

 
  



Step 69 

Insert two more edge loops on top where the two arrows are pointing. And then move 
down to the two vertices where the third arrow is pointing, select them and go to Edit 
Mesh>Merge and merge them. By doing this, the two vertices will become one. Also 
adjust the shape according to the model. 

 
  



Step 70 

Go to the Perspective and insert an edge loop from top. 

 

Step 71 

Select the top faces and extrude them up. 

 



Step 72 

From the Front view, insert four edge loops at right side of the model, and give it shape as 
you can see in the image below. 

 

Step 73 

Insert two more edges from the front and one from the top. 

 



Step 74 

Go to Edit Mesh>Extrude, and extrude something like this. 

 

Step 75 

Select the vertices and move them outward. 

 



Step 76 

Select an edge and extrude it down the side according to the model. Check out the 
proportions of the model at the beginning of the tutorial, the final model. 

 

Step 77 

Now continuing with this part we will create the front part of the gun. First insert an edge 
loop from Front view (see figure.) Go to the Perspective view, select the edges and 
extrude them. 

 



Step 78 

Then also extrude from the bottom and merge the vertices at the last point. 

 
Advertisement 

Step 79 

In the Front view, select the faces from the right side and back side of the gun and delete 
them, as you can see in the figure. 

 



Step 80 

Then close it. Now the base model is almost complete. We will see how to add more 
details to this model in the next part of this tutorial. 

 
 


